External connectivity status

External connectivity status history

Explore the operational status of communication channels in your selected country.

Downtime isn't shown here? Check Infobip system status

Operational

Maintenance

Major outage

Partial outage

Degraded

United States - T-Mobile US - PLANNED OPERATOR MAINTENANCE

Incident Report for External Connectivity

Resolved

Previously announced technical maintenance on T-Mobile US network, United States has been successfully completed. SMS and MMS traffic is now being processed normally. We will continue to monitor the connection to ensure stable performance and no further impact is observed.
Posted Nov 19, 2025 - 20:12 UTC

Investigating

Please be informed that previous T-Mobile US, United States technical maintenance that was scheduled to last from 19.11.2025. 03:00 UTC until 19.11.2025. 13:00 UTC has been extended for 7 hours and will last until until 20:00 UTC.

Channel impacted: SMS | MMS

During the maintenance window, there could be intermittent delays delivering SMS/MMS to handset. We apologies for any inconvenience caused.
Posted Nov 19, 2025 - 14:14 UTC
This incident affected: United States (SMS, MMS).