External connectivity status

External connectivity status history

Explore the operational status of communication channels in your selected country.

Downtime isn't shown here? Check Infobip system status

Operational

Maintenance

Major outage

Partial outage

Degraded

Nigeria - multiple networks - MULTIPLE CHANNEL DEGRADATION

Incident Report for External Connectivity

Update

This is to inform you that the situation towards Nigeria has changed:

USSD - MTN Nigeria, 9mobile - You may experience delays in requesting USSD short codes.
Voice - Glo Mobile - You may experience call failures or disconnects.
SMS - Airtel and 9mobile remain problematic - You may experience irregular delivery with inconsistent delivery times.

Our dedicated engineering team is working with the MNOs to resolve the situation at hand. We will post update as new information is available.
Posted Jul 18, 2025 - 07:19 UTC

Update

This is to inform you that the situation towards Nigeria expedited even further:

USSD - MTN Nigeria, 9mobile - You may experience delays in requesting USSD short codes.
Voice - Glo Mobile - You may experience call failures or disconnects.
SMS - all 4 MNOs, Airtel, MTN, 9mobile and Glo Mobile - You may experience irregular delivery with inconsistent delivery times.

Our dedicated engineering team is working with the MNOs to resolve the situation at hand. We will post update as new information is available.
Posted Jul 18, 2025 - 01:48 UTC

Update

This is to inform you that the situation towards Nigeria expedited even further:

USSD - MTN Nigeria - You may experience delays in requesting USSD short codes.
Voice - Glo Mobile - You may experience call failures or disconnects.
SMS - all 4 MNOs, Airtel, MTN, 9mobile and Glo Mobile - You may experience irregular delivery with inconsistent delivery times.

Our dedicated engineering team is working with the MNOs to resolve the situation at hand. We will post update as new information is available.
Posted Jul 17, 2025 - 07:04 UTC

Update

We are experiencing degradation over multiple channels towards multiple networks in Nigeria:

USSD - MTN Nigeria - You may experience delays in requesting USSD short codes.
Voice - Glo Mobile - You may experience call failures or disconnects.
SMS - 9mobile and Airtel- You may experience irregular delivery with inconsistent delivery times.

Our dedicated engineering team is working with the MNOs to resolve the situation at hand. We will post update as new information is available.
Posted Jul 17, 2025 - 03:18 UTC

Update

We are experiencing degradation over multiple channels towards multiple networks in Nigeria:

USSD - MTN Nigeria - You may experience delays in requesting USSD short codes.
Voice - Glo Mobile - You may experience call failures or disconnects.
SMS - 9mobile - You may experience irregular delivery with inconsistent delivery times.

Please note that the SMS degradation towards Glo Mobile and Airtel has been resolved.

Our dedicated engineering team is working with the MNOs to resolve the situation at hand. We will post update as new information is available.
Posted Jul 16, 2025 - 19:36 UTC

Update

We are experiencing degradation over multiple channels towards multiple networks in Nigeria:

USSD - MTN Nigeria - You may experience delays in requesting USSD short codes.
Voice - Glo Mobile - You may experience call failures or disconnects.
SMS - Glo Mobile and Airtel - You may experience irregular delivery with inconsistent delivery times.

Our dedicated engineering team is working with the MNOs to resolve the situation at hand. We will post update as new information is available.
Posted Jul 16, 2025 - 12:59 UTC

Update

We are continuing to work on a fix for this situation.
Posted Jul 16, 2025 - 14:00 UTC

Update

We are experiencing degradation over multiple channels towards multiple networks in Nigeria:

MTN Nigeria - USSD - You may experience delays in requesting USSD short codes.
Glo mobile - Voice - You may experience call failures or disconnects.

Our dedicated engineering team is working with the MNOs to resolve the situation at hand. We will post update as new information is available.
Posted Jul 15, 2025 - 15:08 UTC

Identified

We are experiencing degradation in requesting USSD short codes towards MTN Nigeria network, Nigeria. Our dedicated engineering team is working with the MNO to resolve the situation at hand, we will post update as new information is available.
Posted Jul 11, 2025 - 06:03 UTC
This incident affects: Nigeria (SMS, Voice, USSD).