External connectivity status

External connectivity status history

Explore the operational status of communication channels in your selected country.

Downtime isn't shown here? Check Infobip system status

Operational

Maintenance

Major outage

Partial outage

Degraded

Canada - Multiple Networks - MMS DELIVERY DEGRADATION

Incident Report for External Connectivity

Update

We are continuing to work on resolving the MMS delivery degradation affecting multiple networks in Canada.

Our engineering team is actively engaged with the MNO and investigations are still ongoing. We do not yet have an ETA for full resolution, but we are treating this as a high priority.

You may continue to experience irregular delivery and inconsistent delivery times for MMS traffic towards the affected Canadian networks.

We will share a further update as soon as new information becomes available. We apologize for the inconvenience and thank you for your patience.
Posted May 19, 2026 - 22:42 UTC

Identified

We are experiencing MMS degradation in delivery towards multiple networks in Canada. You may experience irregular delivery with inconsistent delivery times while sending towards the specified network.

Our dedicated engineering team is working with the MNO to resolve the situation at hand, we will post update as new information is available.
Posted May 19, 2026 - 11:04 UTC
This incident affects: Canada (MMS).